Wrox Programmer Forums

Need to download code?

View our list of code downloads.

| FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
BOOK: Beginning ASP.NET 4 : in C# and VB
This is the forum to discuss the Wrox book Beginning ASP.NET 4: in C# and VB by Imar Spaanjaars; ISBN: 9780470502211
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: Beginning ASP.NET 4 : in C# and VB section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old April 21st, 2013, 07:20 AM
Registered User
Points: 40, Level: 1
Points: 40, Level: 1 Points: 40, Level: 1 Points: 40, Level: 1
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2013
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Default missing ado.net entity

I have no Ado.Net Entity Data Model template when I try to Add New Item in the App_Code folder (the first Try it Out, Chapter 14).

I have looked at other posts as you suggest elsewhere in other threads. There is one where you suggest looking for the file AdoNetEntityDataModelCSharp.zip. I do not have it in :\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\ItemTemplates\CSharp\Data\1033 or anywhere under Microsoft Visual Studio 10.0.

I do however have that file in :\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\ItemTemplates\CSharp\Data\1033 as well in ..\Microsoft Visual Studio 11.0\Common7\IDE\VWDExpress\ItemTemplates\CSharp\D ata\1033. I am wondering because I have Visual Studio Express 2012 on my PC this has caused the problem somehow.

I would be grateful for any advice to get round the problem. Thanks.
Reply With Quote
  #2 (permalink)  
Old April 21st, 2013, 07:44 AM
Imar's Avatar
Wrox Author
Points: 72,055, Level: 100
Points: 72,055, Level: 100 Points: 72,055, Level: 100 Points: 72,055, Level: 100
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 17,086
Thanks: 80
Thanked 1,587 Times in 1,563 Posts
Default

Hi there,

Sounds like a faulty install to me. The one in the Studio 11 comes from VS 2012 indeed so that one seemed to have worked out fine.

A couple of things you can try / may already have tried:

1. http://msdn.microsoft.com/en-us/library/ms247116.aspx - Showe you how to restore the default templates.

2. http://www.microsoft.com/en-gb/downl...s.aspx?id=8363 - Reinstall EF

3. http://stackoverflow.com/questions/5...-ado-net-entit - Other ways to repair EF and the templates.

Finally, if it keeps failing, you can try repairing or reinstalling Visual Studio 2010.

Cheers,

Imar
__________________
Imar Spaanjaars
http://Imar.Spaanjaars.Com
Follow me on Twitter

Author of Beginning ASP.NET 4.5 : in C# and VB, Beginning ASP.NET Web Pages with WebMatrix
and Beginning ASP.NET 4 : in C# and VB.
Did this post help you? Click the button below this post to show your appreciation!
Reply With Quote
  #3 (permalink)  
Old April 22nd, 2013, 03:17 PM
Registered User
Points: 40, Level: 1
Points: 40, Level: 1 Points: 40, Level: 1 Points: 40, Level: 1
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2013
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Default reply

Thanks Imar, for prompt reply

I tried the second option and downloaded Ado.net entity framework 4.1.

It was then showing Ado.Net Dbcontext generator in my templates for the App_code folder, which didn't do anything except generate an error message.

Tried the other options including a reinstall of VWD.

Are there any other ideas or am I missing something obvious?

Thanks
Reply With Quote
  #4 (permalink)  
Old April 22nd, 2013, 03:28 PM
Imar's Avatar
Wrox Author
Points: 72,055, Level: 100
Points: 72,055, Level: 100 Points: 72,055, Level: 100 Points: 72,055, Level: 100
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 17,086
Thanks: 80
Thanked 1,587 Times in 1,563 Posts
Default

One post I came across mentioned installing VS on a D or other drive, while EF and its templates were installed on C, causing an issue.

If you can't make it work, get in touch with Microsoft. VWD is fully supported so you can call them and they'll help you figure it out.

Cheers,

Imar
__________________
Imar Spaanjaars
http://Imar.Spaanjaars.Com
Follow me on Twitter

Author of Beginning ASP.NET 4.5 : in C# and VB, Beginning ASP.NET Web Pages with WebMatrix
and Beginning ASP.NET 4 : in C# and VB.
Did this post help you? Click the button below this post to show your appreciation!
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Raw ADO.NET Repository implementation missing? ENOTTY BOOK: Professional ASP.NET Design Patterns 5 February 25th, 2014 05:21 PM
Chapter 14 - ADO.NET Entity Data Model Sean1980 BOOK: Beginning ASP.NET 4 : in C# and VB 3 July 15th, 2011 12:24 PM
Chapter 14 Linq and ado.net entity framework pandukal21 BOOK: Beginning ASP.NET 4 : in C# and VB 8 January 28th, 2011 05:19 AM
confusing in ADO.NET Entity Data Model,Linq to sql angelboy ADO.NET 5 November 21st, 2008 05:01 PM
Difference between ADO and ADO.NET rakeshclose2u ADO.NET 2 April 23rd, 2007 03:57 AM



All times are GMT -4. The time now is 07:47 PM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.