Wrox Programmer Forums
|
BOOK: Professional Microsoft SQL Server 2008 Reporting Services ISBN: 978-0-470-24201-8
This is the forum to discuss the Wrox book Professional Microsoft SQL Server 2008 Reporting Services by Paul Turley, Thiago Silva, Bryan C. Smith, Ken Withee; ISBN: 9780470242018
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: Professional Microsoft SQL Server 2008 Reporting Services ISBN: 978-0-470-24201-8 section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old February 5th, 2010, 07:35 PM
Authorized User
 
Join Date: Sep 2009
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default Report Builder 1.0 Number Format Problem

I noticed a phenomenon while working on the examples in Chapter 12 and want to confirm what I’m experiencing as anomaly in Report Builder 1.0.

If I create a report from a Report Model which includes the Total Sales Amount aggregate measure from Fact Reseller Sales (as simple as a row for each product category with total sales), the amount cell can be reformatted (e.g,. change the number of decimal places or add the thousands comma delimiter) prior to saving the report. If the cell is formatted and the report saved and later reopened, formatting the amount cell still works. However, if the report is saved without formatting the amount, when it is reopened it is no longer possible to apply numeric formatting as the cell is now treated as a string value. If you right click on the amount cell at this point and select Format, the Number tab does not even appear. This would require recreating the report from scratch in order to apply the formatting if it isn’t completed during initial creation.

This problem does not seem to exist in Report Builder 2.0, which has an interface closer to the SSRS Report Designer. I realize that 1.0 might be phased out but for the purposes of knowing the capabilities of these tools as well as possible, I’m still interested in whether others have noticed this problem or can duplicate.

A number of posts to this forum have a lot of views but no replies. This is disappointing.

Last edited by rmb99; February 6th, 2010 at 11:33 AM.. Reason: More descriptive title





Similar Threads
Thread Thread Starter Forum Replies Last Post
Report Builder 2.0 and Model security barmanvarn Reporting Services 0 July 23rd, 2009 05:46 PM
Report Builder Models? SQLScott Reporting Services 2 October 26th, 2007 01:34 PM
Report in C++ Builder tiago C++ Programming 2 June 15th, 2006 12:29 PM
C++ Builder 6 and Crystal Report rowin C++ Programming 0 April 26th, 2006 05:11 AM
Report Builder Puneet ASP.NET 1.x and 2.0 Application Design 0 September 19th, 2003 09:00 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.