Wrox Programmer Forums

Need to download code?

View our list of code downloads.

| FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
BOOK: Professional XMPP Programming with JavaScript and jQuery
This is the forum to discuss the Wrox book Professional XMPP Programming with JavaScript and jQuery by Jack Moffitt; ISBN: 978-0-470-54071-8
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: Professional XMPP Programming with JavaScript and jQuery section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
 
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old July 6th, 2010, 04:24 PM
Registered User
 
Join Date: Jul 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default BOSH connection manager

Hi,

Is the connection manager at http://bosh.metajack.im:5280/xmpp-httpbind down? Can anyone use it? By simply accessing the link in a browser i get no response, although a week ago it worked just fine ( presented me with a link to XEP-0045 i think).

Trying the example in Chapter 3 (the hello example) i get the following error in the Error Console of Firefox:
Error: 15, securityError, A security sandbox error occured with the flXHR request.
Source File: http://localhost:8273/scripts/flXHR-...loy/flensed.js
Line: 12.

It worked just fine about a week ago, I haven't changed the source code so my guess is that it's some kind of problem with the connection manager.

Any ideas?

Thanks.
  #2 (permalink)  
Old July 6th, 2010, 04:32 PM
Wrox Author
Points: 702, Level: 10
Points: 702, Level: 10 Points: 702, Level: 10 Points: 702, Level: 10
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2010
Posts: 178
Thanks: 0
Thanked 16 Times in 15 Posts
Default

Sorry about that. Linode just did a machine migration yesterday on that box, and I forgot to restart the service.

It should be back up now.
  #3 (permalink)  
Old July 20th, 2010, 12:48 PM
Registered User
 
Join Date: Jul 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default BOSH connection manager

is http://bosh.metajack.im:5280/xmpp-httpbind down ? it was working till last thurday or friday
  #4 (permalink)  
Old July 20th, 2010, 01:10 PM
Wrox Author
Points: 702, Level: 10
Points: 702, Level: 10 Points: 702, Level: 10 Points: 702, Level: 10
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2010
Posts: 178
Thanks: 0
Thanked 16 Times in 15 Posts
Default

It's back up. Sorry about that.
  #5 (permalink)  
Old July 20th, 2010, 06:04 PM
Registered User
 
Join Date: Jul 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Remote-connection-failed

It doesnt connect, below is the request /response

Request

<body rid='1633378233' xmlns='http://jabber.org/protocol/httpbind' to='jabber.org' xml:lang='en' wait='60' hold='1' content='text/xml; charset=utf-8' ver='1.6' xmpp:version='1.0' xmlns:xmpp='urn:xmpp:xbosh'/>


Response

<body xmlns='http://jabber.org/protocol/httpbind' type='terminate' condition='remote-connection-failed'/>
  #6 (permalink)  
Old July 21st, 2010, 11:29 PM
Registered User
 
Join Date: Jul 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

My Hello script is also getting a ConnFailed response.

When I go directly to http://bosh.metajack.im:5280/xmpp-httpbind I can see the page with the XEP-0124 link but when I run the Hello test page on my local server, the connection attempt results in a status of 2. So basically the test just stalls, since it never reaches the "connected" or "disconnected" state.
  #7 (permalink)  
Old December 4th, 2010, 04:47 PM
Wrox Author
Points: 702, Level: 10
Points: 702, Level: 10 Points: 702, Level: 10 Points: 702, Level: 10
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2010
Posts: 178
Thanks: 0
Thanked 16 Times in 15 Posts
Default

Quote:
Originally Posted by twine View Post
My Hello script is also getting a ConnFailed response.

When I go directly to http://bosh.metajack.im:5280/xmpp-httpbind I can see the page with the XEP-0124 link but when I run the Hello test page on my local server, the connection attempt results in a status of 2. So basically the test just stalls, since it never reaches the "connected" or "disconnected" state.
This is probably a cross-domain issue. What URL are you serving the hello.html page from?
  #8 (permalink)  
Old January 12th, 2011, 09:07 AM
Registered User
 
Join Date: Jan 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Down again

Hi,
it seems like the BOSH-Server: http://bosh.metajack.im:5280/xmpp-httpbind
is down again.

It woul be realy kind if you could fix this issue since I need the server for testing purpose.

thanks a lot
  #9 (permalink)  
Old January 13th, 2011, 02:43 PM
Authorized User
 
Join Date: Jan 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The best solution for this problem is to setup your own XMPP server. Its very simple, follow the instructions in the Appendix. It will not take more than 10 mins
  #10 (permalink)  
Old January 17th, 2011, 01:38 PM
Wrox Author
Points: 702, Level: 10
Points: 702, Level: 10 Points: 702, Level: 10 Points: 702, Level: 10
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2010
Posts: 178
Thanks: 0
Thanked 16 Times in 15 Posts
Default

Quote:
Originally Posted by kb1605 View Post
Hi,
it seems like the BOSH-Server: http://bosh.metajack.im:5280/xmpp-httpbind
As far as I can tell it hasn't been down for quite some time. My guess is that there was a routing issue somewhere that prevented your systems from reaching it?

I just double checked that http://bosh.metajack.im:5280/xmpp-httpbind responds in my browser fine.

Let me know if you continue to have problems and I'll dig into it.
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
script manager MunishBhatia Ajax 0 January 29th, 2009 10:22 AM
related to connection manager in ssis. pravasis SQL Server 2005 0 July 2nd, 2007 11:41 PM
Enterprise Manager/SQL Connection Problem wdfadude SQL Server 2000 1 July 14th, 2005 02:22 PM
Switchboard Manager penta Access 2 March 10th, 2005 06:43 AM
What DB manager to use? elde SQL Server ASP 2 January 5th, 2005 05:39 AM



All times are GMT -4. The time now is 03:14 AM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.