Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > C# and C > C# 2005 > C# 2005
Password Reminder
Register
| FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
C# 2005 For discussion of Visual C# 2005.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the C# 2005 section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
 
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old February 22nd, 2006, 03:18 PM
Authorized User
 
Join Date: Jun 2003
Location: , , .
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default Invalid class string - : 0x800401F3

I'm not sure what happened. Last week I run windows update on my computer. I have .net 2.0 & VS 2005 installed. Now anytime, I open my c# project w/ View Designer, I've got an error:

One or more errors encountered while loading the designer. The errors are listed below. Some errors can be fixed by rebuilding your project, while others may require code changes.

Invalid class string (Exception from HRESULT: 0x800401F3 (CO_E_CLASSSTRING))
Hide

at System.Windows.Forms.UnsafeNativeMethods.CoCreateI nstance(Guid& clsid, Object punkOuter, Int32 context, Guid& iid)
at System.Windows.Forms.AxHost.CreateWithoutLicense(G uid clsid)
at System.Windows.Forms.AxHost.CreateInstanceCore(Gui d clsid)
at System.Windows.Forms.AxHost.CreateInstance()
at System.Windows.Forms.AxHost.GetOcxCreate()
at System.Windows.Forms.AxHost.set_Site(ISite value)
at System.ComponentModel.Container.Add(IComponent component, String name)
at System.ComponentModel.Design.DesignerHost.Add(ICom ponent component, String name)
at System.ComponentModel.Design.DesignerHost.System.C omponentModel.Design.IDesignerHost.CreateComponent (Type componentType, String name)
at System.ComponentModel.Design.Serialization.Designe rSerializationManager.CreateInstance(Type type, ICollection arguments, String name, Boolean addToContainer)
at System.ComponentModel.Design.Serialization.Designe rSerializationManager.System.ComponentModel.Design .Serialization.IDesignerSerializationManager.Creat eInstance(Type type, ICollection arguments, String name, Boolean addToContainer)
at System.ComponentModel.Design.Serialization.CodeDom SerializerBase.DeserializeInstance(IDesignerSerial izationManager manager, Type type, Object[] parameters, String name, Boolean addToContainer)
at System.ComponentModel.Design.Serialization.Compone ntCodeDomSerializer.DeserializeInstance(IDesignerS erializationManager manager, Type type, Object[] parameters, String name, Boolean addToContainer)
at System.ComponentModel.Design.Serialization.CodeDom SerializerBase.DeserializeExpression(IDesignerSeri alizationManager manager, String name, CodeExpression expression)
at System.ComponentModel.Design.Serialization.CodeDom Serializer.DeserializeStatementToInstance(IDesigne rSerializationManager manager, CodeStatement statement)
at System.ComponentModel.Design.Serialization.CodeDom Serializer.Deserialize(IDesignerSerializationManag er manager, Object codeObject)
at System.Windows.Forms.Design.ControlCodeDomSerializ er.Deserialize(IDesignerSerializationManager manager, Object codeObject)
at System.ComponentModel.Design.Serialization.TypeCod eDomSerializer.DeserializeName(IDesignerSerializat ionManager manager, String name, CodeStatementCollection statements)

It was fine before and now it's error where it never error before. Same project is fine when open on other computer.

I search on google.com & microsoft.com but I didn't found any case that same as mine.

I already re-install VS2005, .net 2.0 a few time but it still didn't work. If anybody could give me some advice, please let me know. I'll appreciate that.

  #2 (permalink)  
Old March 16th, 2006, 04:53 PM
Registered User
 
Join Date: Mar 2006
Location: , , .
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

not24...im not sure if this will help you but i was having the same problem that you were having and, although it boggles my mind that it worked, all i did was rename the form that was giving me the problem, compile, and then rename it back and recompile. i am still haveing the problem in the design view of my .resx files...

i get warnings:

The system cannot find the path specified. (Exception from HRESULT: 0x80070003)

but it compiles and runs fine.


Rick Graham
Web Development / Junior Programmer

 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Invalid class string ASP 0177 (0x800401F3) crmpicco Classic ASP Basics 12 June 16th, 2007 11:44 PM
Invalid class string CH 6 itpro2 BOOK: Beginning ASP 3.0 0 May 22nd, 2006 05:15 PM
ASPUPLOAD issue: ="Invalid Class String"= Calverstine Classic ASP Basics 1 August 10th, 2005 05:34 AM
Invalid ProgId ASP 0177 (0x800401F3) saravananedu Classic ASP Components 5 June 8th, 2004 07:31 AM



All times are GMT -4. The time now is 01:53 AM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.