Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > C# and C > C# 2005 > C# 2005
Password Reminder
Register
| FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
C# 2005 For discussion of Visual C# 2005.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the C# 2005 section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
 
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old October 29th, 2008, 04:17 PM
Authorized User
 
Join Date: Nov 2006
Location: Valparaiso, IN, USA.
Posts: 93
Thanks: 0
Thanked 1 Time in 1 Post
Default Unable to get installer types ...

I have a nice little plugin application that I built but cannot install on any other pc that I have tried. I have verified that the test pcs have the target application and that they have the same version of Microsoft.Net Framework (2.0.50727).

I have tried it with the shared resources (from the target application) included in the setup file and without them. Either way the install gets nearly to the end (based on the idea that the files have already been copied to the target directory) and I get a message saying,

Unable to get installer types in the <plugin.dll path> assembly. --> Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

I copied fuslogvw.exe to one of the test machines and don't see any problems with the fussion log. The last two lines of the log are:

LOG: Binding succeeds. Returns assembly from C:\Program Files\PIPC\Procbook\Addins\TrendXpndr\TrendXpndr.d ll.
LOG: Assembly is loaded in LoadFrom load context.

This appears to be a common problem but I have yet to find and answer.

Does anyone have an idea on how I could get my application to install?

Thanks

What you don't know can hurt you!
__________________
What you don\'t know can hurt you!
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Microsot Installer - Need Help The Beginner .NET Framework 1.x 2 January 1st, 2015 02:42 AM
Run an installer anubisascends Beginning PHP 0 June 24th, 2007 01:35 PM
WinServices Installer rferrill BOOK: Professional C#, 2nd and 3rd Editions 1 June 15th, 2004 10:20 PM
How to create an installer? thiNkspAce VB How-To 2 March 3rd, 2004 07:14 AM
Installer Question mruthven Pro VB.NET 2002/2003 0 September 17th, 2003 12:28 PM



All times are GMT -4. The time now is 11:09 PM.


Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.