Wrox Programmer Forums
Go Back   Wrox Programmer Forums > .NET > Other .NET > Crystal Reports
| Search | Today's Posts | Mark Forums Read
Crystal Reports General discussion about Crystal Reports. For discussions specific to the book Professional Crystal Reports for VS.NET, please see the book discussion forum for that book.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Crystal Reports section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old October 12th, 2003, 07:25 PM
Registered User
 
Join Date: Oct 2003
Location: , , .
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default CR.NET NOT DISPLAYING IMAGE

Hi all,

I have a simple web form written in vb.net which contains a crystal report viewer. In vs.net web form designer, while all data fields are shown correctly, only a red "X" is displayed where there should be
images for the tool bar buttons, tree view and Crystal Report logo (but I can see the sample chart image). And when I access the web form from a browser, NO CR.Net-generated image, including chart is displayed.

Can anybody help me out?

Thank you in advance!


 
Old October 14th, 2003, 10:35 AM
Registered User
 
Join Date: Oct 2003
Location: Edison, NJ, USA.
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Try creating a virtual directory which maps to:

C:\Program Files\Common Files\Crystal Decisions\2.0\crystalreportviewers\images\toolbar

I had this problem, I think it was fixed after creating this virtual directory.

HTH
Akhtar
 
Old October 14th, 2003, 09:20 PM
Registered User
 
Join Date: Oct 2003
Location: , , .
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

:)
It works!
Thank you Akhtar!


 
Old October 28th, 2003, 11:53 AM
Registered User
 
Join Date: Oct 2003
Location: , , .
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

For VS.NET 2003, create a virtual web directory called CrystalReportWebFormViewer2 which maps to:
C:\Program Files\Microsoft Visual Studio .NET 2003\Crystal Reports\Viewers

Jim

 
Old February 8th, 2005, 02:35 AM
Registered User
 
Join Date: Feb 2005
Location: Karachi, Sindh, Pakistan.
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to dungerdanish Send a message via Yahoo to dungerdanish
Default

Hi, I'm also having the same problem with crystal reports for VS.net

the toolbar is displaying correctly in the webform but where there supposed to be a chart is the red ouline of the chart with the red "X" but no chart, I have checked, the virtual directories are already mapped

Any suggestions?

 
Old May 23rd, 2006, 07:09 AM
Registered User
 
Join Date: May 2006
Location: , , .
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

 my virtual web directory called CrystalReportWebFormViewer2 is already maps to:
C:\Program Files\Microsoft Visual Studio .NET 2003\Crystal Reports\Viewers
 still unable to dispaly image... pls help...

 
Old October 15th, 2008, 06:29 AM
Registered User
 
Join Date: Oct 2008
Location: , , .
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

how to create viruval directory and map to the given root?





Similar Threads
Thread Thread Starter Forum Replies Last Post
Displaying Image in RSS Feed with Vb.Net hugh@kmcnetwork.com VB.NET 0 July 9th, 2007 09:09 PM
Image not displaying shoakat ASP.NET 2.0 Professional 2 June 22nd, 2007 10:02 AM
CR.Net Not Showing Logo Image as well as Graphical Johnsony2k3 Crystal Reports 14 May 20th, 2006 01:35 PM
displaying an image from file stream into an image sanjeet ADO.NET 0 September 23rd, 2005 10:28 AM
dynamic image display in CR in asp.net mpkrishna Crystal Reports 0 March 29th, 2005 01:44 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.