Wrox Programmer Forums
Go Back   Wrox Programmer Forums > Web Programming > CSS > CSS Cascading Style Sheets
|
CSS Cascading Style Sheets All issues relating to Cascading Style Sheets (CSS).
Welcome to the p2p.wrox.com Forums.

You are currently viewing the CSS Cascading Style Sheets section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old March 19th, 2008, 10:02 AM
Banned
 
Join Date: Jul 2005
Posts: 317
Thanks: 0
Thanked 0 Times in 0 Posts
Default Linked Images in Firefox Showing Underline

My site's links have the text-decoration property set to "underline". In Firefox, the linked images are showing an underline, but in IE and other browsers, that underline doesn't show up.

I've seen some other articles and posts (like http://archivist.incutio.com/viewlist/css-discuss/56774), and the only solution I've found that works is "display:block;". I cannot use that property in my site, as it moves the images from where they are supposed to be. Does anyone know of another way to make this work?

P.S. This is what I currently have my "img" CSS property set to:
img {
    border:none;
    text-decoration:none;
    line-height:0;
}

KWilliams
 
Old March 27th, 2008, 03:01 PM
Registered User
 
Join Date: Mar 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default


 I have never had this problem in either browser, here is a simple example that has a image as a link, and links are set to underline and i do not see any underline on the image in IE6,7 or FF or Opera.

http://www.createamobilesite.com

Your problem might be that you need a CSS reset. Check out the CSS for it at http://www.createamobilesite.com/style.css

Basically look at everything from the top to the body style, try using that part in your CSS and see if it fixes the issue.

Also you should try FireBug for Firefox for CSS debugging.

.NET Developer @ http://www.3mushrooms.com





Similar Threads
Thread Thread Starter Forum Replies Last Post
images not showing in IE Adam H-W CSS Cascading Style Sheets 3 March 20th, 2008 07:02 AM
ODBC linked table showing old data (not refreshing d-fxt Access 3 November 14th, 2007 05:56 PM
showing images from database umair_rathore Classic ASP Databases 1 April 23rd, 2005 04:46 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.