Wrox Programmer Forums
Go Back   Wrox Programmer Forums > .NET > Other .NET > General .NET
|
General .NET For general discussion of MICROSOFT .NET topics that don't fall within any of the other .NET forum subcategories or .NET language forums.  If your question is specific to a language (C# or Visual Basic) or type of application (Windows Forms or ASP.Net) try an applicable forum category. ** PLEASE BE SPECIFIC WITH YOUR QUESTION ** When posting here, provide details regarding the Microsoft .NET language you are using and/or what type of application (Windows/Web Forms, etc) you are working in, if applicable to the question. This will help others answer the question without having to ask.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the General .NET section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old January 6th, 2005, 08:41 AM
Registered User
 
Join Date: Dec 2004
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default aspx file not working

When I create an aspx file and place it in to the wwwroot folder then go to view it in IE6 eg. http://localhost/name.aspx all that appears on the page is the text within the html tags?

When I right-click on the page in IE6 and 'view source' the source code is the exact code that I have put in to the page including all the VB.NET code and delimiters?

I have set all the security permissions to full for everthing on the wwwroot folder. Execute all scripts etc.

It's like it doesn't compile the code and then display it. I think.

I'm running W2K.

Can anyone shed any light on this for me?

Cheers

Kefi2927

Think big thoughts, but relish small pleasures
 
Old January 6th, 2005, 08:55 AM
Authorized User
 
Join Date: Oct 2004
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Check the properties of the page as it may be Text page besides aspx page.

Amit

 
Old January 7th, 2005, 06:46 AM
Registered User
 
Join Date: Dec 2004
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi thanks for your help.

Apparently I'd installed IIS after the .NET framework and I needed to register ASP.NET.

Below is a fix for this problem:

-------------------------------------------------
You can register ASP.NET by going to %SYSTEM%\Microsoft.NET\Framework\<version of framework>\ folder. Locate 'aspnet_regiis.exe' program in that folder, and run it on command line with -i switch that is run 'aspnet_regiis -i' from the aforementioned folder.
--------------------------------------------------

Hope this helps others

Cheers

Think big thoughts, but relish small pleasures





Similar Threads
Thread Thread Starter Forum Replies Last Post
document.element isn't working in aspx page SOLVED logidude ASP.NET 1.0 and 1.1 Basics 2 June 29th, 2007 01:44 PM
Calling a function from .vb file to aspx file !! NitinJoshi General .NET 4 February 10th, 2005 06:23 AM
ShowArchive.aspx is not working groupmatch BOOK: ASP.NET Website Programming Problem-Design-Solution 2 October 22nd, 2004 10:44 PM
my aspx.net first page is not working Raz Muhammad .NET Web Services 2 March 7th, 2004 09:06 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.