Wrox Programmer Forums
|
General .NET For general discussion of MICROSOFT .NET topics that don't fall within any of the other .NET forum subcategories or .NET language forums.  If your question is specific to a language (C# or Visual Basic) or type of application (Windows Forms or ASP.Net) try an applicable forum category. ** PLEASE BE SPECIFIC WITH YOUR QUESTION ** When posting here, provide details regarding the Microsoft .NET language you are using and/or what type of application (Windows/Web Forms, etc) you are working in, if applicable to the question. This will help others answer the question without having to ask.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the General .NET section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old June 22nd, 2007, 07:56 PM
Authorized User
 
Join Date: Feb 2007
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default Deploy to Web

I'm trying to allow people to download a VBExpress.NET program from the web. I've successfully published TheProgram to the web. The install button on the published web page downloads the SETUP.EXE file to the users computer. However, when the SETUP.EXE file is run all it does in install is a file called TheProgram.application. When TheProgram.application is run it produces the following:
Cannot download the application. The application is missing required files. Contact application vendor for assistance.

If I publish the program to my computer it creates TheProgram.EXE that runs fine. It also creates a SETUP.EXE file that has the same problem as the one downloaded from the web.

I appear to be missing something when it comes to publishing to the web, but I sure can't figure out what it is. Any help would be appreciated.

Thanks, Lowell

 
Old June 25th, 2007, 06:08 AM
planoie's Avatar
Friend of Wrox
 
Join Date: Aug 2003
Posts: 5,407
Thanks: 0
Thanked 16 Times in 16 Posts
Default

As the error indicates it is missing files. Do you have files in your application that are required by are not being deployed? Check the properties on the files. There should be one property that indicates what the compile or deployment behavior is. It will dictate whether the files gets packaged with the deployment.

-Peter
 
Old June 25th, 2007, 10:22 AM
Authorized User
 
Join Date: Feb 2007
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the reply. Unfortunately, I think you are missing my point. The SETUP.EXE in not installing the TheProgram.EXE file. There are no additional files required.

 
Old October 18th, 2007, 10:58 AM
Registered User
 
Join Date: Oct 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

IMPORTANT NOTE: The current version of ClickOnce will only work properly in Internet Explorer. In particular if you try to download using Firefox the following error message will appear:

"Cannot Start Application. Cannot download the application. The application is missing required files. Contact application vendor for assistance."

Microsoft are working on cross browser support for ClickOnce - if you're interested read more here.
A patch for Firefox that will enable it to run ClickOnce properly is available here.






Similar Threads
Thread Thread Starter Forum Replies Last Post
Not able to Deploy my First Web Application shankarnj Apache Tomcat 5 February 28th, 2017 09:57 AM
Deploy Crystal Reports to the Web pespcid Crystal Reports 4 March 30th, 2011 08:17 PM
Deploy web site forumsudhir Internet Information Services 0 July 4th, 2007 08:50 AM
How to deploy Web Application on JBoss inderjeet_79 J2EE 0 November 21st, 2005 06:30 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.