Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > Visual Basic > VB 6 Visual Basic 6 > Pro VB 6
Password Reminder
Register
| FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
Pro VB 6 For advanced Visual Basic coders working in version 6 (not .NET). Beginning-level questions will be redirected to other forums, including Beginning VB 6.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Pro VB 6 section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old September 14th, 2006, 11:13 PM
Registered User
 
Join Date: May 2006
Location: Noida, UP, India.
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Error no 70 Permission Denied

Hi,

I have developed an application in VB6.0, SQL Server 2000 & Crystal Reports 8.5. OS is Win2000 Prof. with SP4.

There is report which has an OLE object for displaying images at runtime according to the ItemCode. Each ItemCode has got different Image stored in Image folder on Server. This report also has few subreports.

OLE object is linked to a .bmp file in 'C' drive.
As my application runs, it changes the .bmp image in 'C' drive (using Fso object) according to the ItemCode and the changed image is to be reflected on running the report.

Problem is this report works fine some machines but it doesn't working in some machines also. All machines has same configuration.

In one machine it pops-up a message "ERROR No 70 Permission denied.". After that report run successfully without changing the image.

In one machine it doesn't pops-up anything but report runs successfully without changing the image.

In other machines, report runs absolutely fine.

I have gone through the net and found 'dcomconfg' got some setting for solving "Error no 70". I don't know what setting to be changed.

I am also confused for what to do where reports are not working and no error msg are popping.

Please help and advice

Thanks & Regards
rupak





Reply With Quote
  #2 (permalink)  
Old October 3rd, 2006, 11:36 PM
Registered User
 
Join Date: May 2006
Location: Noida, UP, India.
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

Please suggest! ! !

This is very urgent.


Thanks & Regards

Reply With Quote
  #3 (permalink)  
Old October 4th, 2006, 08:36 AM
Friend of Wrox
Points: 7,395, Level: 36
Points: 7,395, Level: 36 Points: 7,395, Level: 36 Points: 7,395, Level: 36
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Capital Federal, , Argentina.
Posts: 2,189
Thanks: 5
Thanked 59 Times in 57 Posts
Send a message via MSN to gbianchi
Default

hi there..

i get error 70 when i try to delete some folders that were used previously...

the only thing I'm sure if that you get it when you have the file in use...

HTH

Gonzalo
Reply With Quote
  #4 (permalink)  
Old October 4th, 2006, 11:27 PM
Registered User
 
Join Date: May 2006
Location: Noida, UP, India.
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

thanks for the reply.

Well I am using File system object to delete a file and Copy a file.

Actually these are .bmp & .jpg files. Among these files, .bmp file is linked to OLE Object in Report created in Crystal Report 8.5.

I have tried "On Error goto" to check for the error line but failed.

Please suggest



Thanks & Regards



Reply With Quote
  #5 (permalink)  
Old October 5th, 2006, 12:55 PM
Friend of Wrox
 
Join Date: Nov 2004
Location: Port Orchard, WA, USA.
Posts: 1,621
Thanks: 1
Thanked 3 Times in 3 Posts
Default

You need to divide the problem into smaller pieces to find out which part is giving you this trouble.

In your code, prior to setting the image, see if you can access the file that you are about to use. If you get the error at that point, then the problem is a file access error.

If you can access the file with no errors, but when you try to point the control at it you get an error, then the control would seem to be the problem (though you could create a small .bmp that everyone has access to, and upon an error with this second part switch to trying to load that all-have-access bitmap to see if that will load fine. If so then the control is OK, the file is OK, but the control does not have the neccessary access to that file that your program [u]does</u> have access to.)

After looking at the individual pieces, and assessing where the problem lies, it will be easier to advise you.
Reply With Quote
  #6 (permalink)  
Old October 7th, 2006, 01:26 AM
Registered User
 
Join Date: May 2006
Location: Noida, UP, India.
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,
hanks for the advice.
I am in process to divide the whole application into capsules application.
Let's hope for the best.

Anyway, i have run my application with F8 (line by line execution) on the system which doesn't show the changed image in Crystal report.

Nothing happens. ! ! !

It doesn't throw any error but at the same time image remains the same.

Any Idea!!



Thanks & Regards



Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting a permission denied error in IE 7 disto Javascript 1 September 20th, 2007 08:26 AM
Permission Denied Error interrupt Javascript How-To 6 October 15th, 2004 05:26 AM
"70 Permission Denied" error in Windows 98 benoyraj VB How-To 0 May 3rd, 2004 12:53 PM
Permission Denied Error in VBA ebalch24 Access VBA 3 April 12th, 2004 06:51 PM
Error 70: Permission denied junglem@n VB How-To 2 April 3rd, 2004 03:42 AM



All times are GMT -4. The time now is 04:56 PM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.