Wrox Programmer Forums
|
Crystal Reports General discussion about Crystal Reports. For discussions specific to the book Professional Crystal Reports for VS.NET, please see the book discussion forum for that book.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Crystal Reports section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old December 5th, 2006, 08:56 AM
Registered User
 
Join Date: Dec 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Load Report Failed

I am facing a trouble in using the crystal report for VS 2005.I have develop a web site using crystal report that comes with the VS 2005.

I have published it to the web server. Application was running fine or a few days. Suddenly it generates the error Load Report Failed when the line of code executes, MyReport.Load(ReportPath).

If I reset IIS server or restart the server it works fine for a couple of days and generates the same error repeatedly.

Also this error occurs when running any report with many users and once the error occurs all reports get the error.

Any Ideas??



 
Old December 17th, 2006, 03:36 AM
Registered User
 
Join Date: Apr 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi

U get this as the export dll fails ...
Just redesign the report and in the text fields dont leave any space as the export dll does nt support that...
i had the same problem and it got solved when I redesigned the entire reoprt and saw that the text boxes in the report did not have ant spaces at the end or a balnk line.

Ashok Rao
 
Old December 17th, 2006, 10:00 PM
Registered User
 
Join Date: Dec 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I faced similar problems with craigbtx, can you explain a little bit more on what's mean by "in the text fields dont leave any space "

 
Old December 18th, 2006, 06:26 AM
Registered User
 
Join Date: Dec 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i too faced the same problem and now its working fine when iis server is restarted.

but it works for sometimes.

is there any other way to make it work fine

wats the relation between space and export dll

pl help me urgent

thanks in advance
sridhar

 
Old December 18th, 2006, 09:15 PM
Registered User
 
Join Date: Dec 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have solved this problem. For my case I have found that the report will throw an exception if there is a total of 75 reports generated. 75 is the default value that is set in the registry in crystal report for Visual Studio 2005. We can simply close and dispose the report object everytime we generate the report and it works prefect now. Hope can help.






Similar Threads
Thread Thread Starter Forum Replies Last Post
load report failed zaghmout Crystal Reports 2 December 3rd, 2007 05:04 AM
Load Report Failed Error mh Crystal Reports 3 October 22nd, 2006 09:08 AM
Load Report Failed - Invalid Table Number rstaubitz Crystal Reports 0 December 28th, 2005 10:07 AM
Load Report Failed Error mh .NET Framework 2.0 2 October 18th, 2005 11:10 AM
Load report failed v_ganeshraju Crystal Reports 0 September 20th, 2004 08:51 PM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.