Wrox Programmer Forums
Go Back   Wrox Programmer Forums > .NET > .NET 1.0 and Visual Studio.NET > VS.NET 2002/2003
|
VS.NET 2002/2003 Discussions about the Visual Studio.NET programming environment, the 2002 (1.0) and 2003 (1.1). ** Please don't post code questions here ** For issues specific to a particular language in .NET, please see the other forum categories.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the VS.NET 2002/2003 section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old July 7th, 2004, 07:52 AM
Registered User
 
Join Date: Jul 2004
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default .Net Remote Debugging problem - Please help!!

Hi,

I currently am trying to set up remote debugging for ASP.NET. Here is my current set up:

Server:
Windows 2003 EE/IIS6
Full/Complete installation of Visual Studio.Net 2003
IIS is set up in the following way: Anonymous Security (using the IUSR account) & Integrated Windows Authentication
Front Page Server Extensions installed

Client:
Win XP Pro
VS.Net 2003

I am creating projects in VS.Net on the server from the client. There is no problem doing this.
I can do a Debug-> Start without debugging and everything works fine but when I try to debug the Web App I get the following error message:
<center>Error while trying to run project: Unable to start debugging on the web server. Access is denied. Verify that you are an administrator or a member of the debugger users group on the machine that you are trying to debug. After being added to the debugger users group you must log off and log back on for the settings to apply.</center>
I am a member of the administrators Group and Debugger Users group on the server!

The 2 machines are on the same domain.

Any ideas?

Thanks,
Peter

 
Old July 7th, 2004, 07:55 AM
Registered User
 
Join Date: Jul 2004
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Forgot to mention also:

I can debug local projects on the server from the server.
I can debug local projects on the client from the client.

 
Old July 7th, 2004, 12:00 PM
planoie's Avatar
Friend of Wrox
 
Join Date: Aug 2003
Posts: 5,407
Thanks: 0
Thanked 16 Times in 16 Posts
Default

I honestly think that remote debugging only works in the perfect world of Microsoft's internal development network because I have never heard of it working. (I'm lucky if I can get LOCAL debugging working!)
 
Old August 16th, 2004, 07:21 PM
Registered User
 
Join Date: Aug 2004
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Check your internet setings on your client.

In my case IE was using anonomous login - changed it to use automatically login as current user and all worked as expected.





Similar Threads
Thread Thread Starter Forum Replies Last Post
Chapter 2 Configuring Remote Debugging GarethHowell BOOK: Professional SharePoint 2007 Development ISBN: 978-0-470-11756-9 1 July 8th, 2008 12:14 PM
[RESOLVED] Remote Debugging Issue dparsons ASP.NET 1.0 and 1.1 Professional 1 March 19th, 2007 01:19 PM
Remote Debugging BSkelding ASP.NET 1.0 and 1.1 Basics 0 February 15th, 2005 12:32 PM
remote debugging not working neethling VS.NET 2002/2003 1 November 16th, 2004 02:38 AM
Remote debugging of a windows service jaucourt Pro VB.NET 2002/2003 2 June 17th, 2004 02:49 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.