Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > Visual Basic > VB 6 Visual Basic 6 > Pro VB 6
Password Reminder
Register
| FAQ | Members List | Search | Today's Posts | Mark Forums Read
Pro VB 6 For advanced Visual Basic coders working in version 6 (not .NET). Beginning-level questions will be redirected to other forums, including Beginning VB 6.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Pro VB 6 section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old May 9th, 2007, 07:10 AM
Registered User
 
Join Date: May 2007
Location: Johannesburg, Gauteng, South Africa.
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default -2147024769 Automation Error on MS Win Server 2003

Could someone please help me with this one.

We have an application that runs at approx 160 clients.
It was developed using VB6, SQL Server / MS Access and it interfaces with MS Office.

We recently from switched using from MDAC 2.5 to MDAC 2.8 with any problems.

One of Our clients only recently downloaded the new version of the software, and after installing it, they get the following error:
-2147024769 "Automation Error"

I've check the versions of all the software and components, including MDAC, and they all seem to be ok.

They are as follows:
Windows Server Std Ed. 2003 SP1;
MS Office 2003;
IE6 SP1
MDAC 2.8 RTM
SQL Server 2000

I think that the error is somehow related to MDAC as we have a small external app that is used to set up the connection settings of the App to the SQL Server Database.

This generates the same error.

The version of msado15.dll running on this machine is 2.82.1???, which seems to be post MDAC 2.8 SP1.

Any ideas anyone? Please....

Thanks in advance
Neil
Reply With Quote
  #2 (permalink)  
Old May 10th, 2007, 02:56 AM
Registered User
 
Join Date: May 2007
Location: Johannesburg, Gauteng, South Africa.
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've managed to narrow it down to being a problem with MDAC.
My problem now is that in order to fix it, I have to try and uninstall MDAC and re-install it, which in itself is almost a no-go zone.

The version of MDAC running on this Server is MDAC 2.8 SP2 which comes with Microsoft Windows Server 2003 SP 1, and unstalling the SP will open up a whole new can of worms as far as other software running on the server is concerned.

Any ideas?

Thanks in advance
Reply With Quote
  #3 (permalink)  
Old May 10th, 2007, 08:07 AM
Friend of Wrox
Points: 7,395, Level: 36
Points: 7,395, Level: 36 Points: 7,395, Level: 36 Points: 7,395, Level: 36
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Capital Federal, , Argentina.
Posts: 2,189
Thanks: 5
Thanked 59 Times in 57 Posts
Send a message via MSN to gbianchi
Default

Can you just re compile it with the actual MDAC?? or at least do a version for the server using that MDAC??

HTH

Gonzalo

================================================== =========
Read this if you want to know how to get a correct reply for your question:
http://www.catb.org/~esr/faqs/smart-questions.html
^^Took that from dparsons signature and he Took that from planoie's profile
================================================== =========
My programs achieved a new certification (can you say the same?):
WORKS ON MY MACHINE
http://www.codinghorror.com/blog/archives/000818.html
================================================== =========
I know that CVS was evil, and now i got the proof:
http://worsethanfailure.com/Articles...-Hate-You.aspx
================================================== =========
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unidcode utf-8 in iis 6.0 win server 2003 cyus Classic ASP Components 0 September 22nd, 2005 04:45 AM
win server 2003 problem slavni Classic ASP Databases 6 April 13th, 2005 03:32 AM
Sending email on win 2003 server md_haris VBScript 3 October 21st, 2004 12:20 PM
Unable to login running on win server 2003 kiekar BOOK: ASP.NET Website Programming Problem-Design-Solution 2 May 6th, 2004 09:28 PM
Access is denied - run on Win Server 2003 jackchua BOOK: ASP.NET Website Programming Problem-Design-Solution 3 April 15th, 2004 05:50 PM



All times are GMT -4. The time now is 08:02 AM.


Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.