Wrox Programmer Forums
|
VB Components Issues specific to components in VB.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the VB Components section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old June 2nd, 2006, 08:23 AM
Registered User
 
Join Date: Jun 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default COM Interop Error on 64bit ?

Hi,

I have create a COM class in VB.Net VS 2005, which works and runs fine for use in classic asp.
Tested it with IIS5 and IIS 6 : No problem

Now when installing it (using same setup project through VS) on a X64 machine it fails.

Caling it from a classic asp page :
ActiveX component can't create object

Calling it from .net gives :
Retrieving the COM class factory for component with CLSID {B6AA7C90-FF32-4353-8537-89A872E298D1} failed due to the following error: 80040154.

Is it not registered correctly ? I hought the setup would do this ?
Is there another problem ?

Thanks for any help
Arne


[/quote]






Similar Threads
Thread Thread Starter Forum Replies Last Post
Sql 2000 enterprise edition(64bit) install probs jecko SQL Server 2000 2 February 17th, 2007 11:01 AM
problem connecting .net with access in 64bit darkelf ADO.NET 1 September 26th, 2006 05:26 PM
ASP.net 1.1 + 64bit support shaharru ASP.NET 1.0 and 1.1 Professional 0 September 21st, 2006 07:34 AM
COM Interop Error on 64bit ? rattatosk Pro Visual Basic 2005 1 August 24th, 2006 10:56 AM
COM Interop Error on 64bit ? rattatosk VS.NET 2002/2003 0 June 2nd, 2006 08:19 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.