Wrox Programmer Forums

Need to download code?

View our list of code downloads.

| FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Dreamweaver (all versions) section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old January 30th, 2006, 01:57 PM
Authorized User
 
Join Date: Jan 2006
Location: , , .
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Default Dw Mx

Hi I have just completed the MediaEdge site, all the .asp pages work individually fine, but when the index page is loaded the only things I can see are the physical elements ie logo and search tool.
the browser shows error messages that line 12 blockNav object expected.
I have double and triple checked all setting from the datbase....any help would be appreciated

Mike

Reply With Quote
  #2 (permalink)  
Old January 30th, 2006, 03:11 PM
Imar's Avatar
Wrox Author
Points: 72,073, Level: 100
Points: 72,073, Level: 100 Points: 72,073, Level: 100 Points: 72,073, Level: 100
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 17,089
Thanks: 80
Thanked 1,587 Times in 1,563 Posts
Default

Hi there,

Do you get the same error when you run the code that comes with the book (that you can download from this site)?

Imar
---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.
Reply With Quote
  #3 (permalink)  
Old January 30th, 2006, 03:48 PM
Authorized User
 
Join Date: Jan 2006
Location: , , .
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Thanks for replying, no there is no code with this error, just a little yelloe box on he bottom left of the page... I have been at this for some time, and cant just see why i'm getting nothing.

Mike

Reply With Quote
  #4 (permalink)  
Old January 30th, 2006, 04:26 PM
Authorized User
 
Join Date: Jan 2006
Location: , , .
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry I misread you reply, I have worked thru out the book as iI want to learn rather than just copy, after several attempts to get it to work I then checked the downloaded files against what I had done. And also read some of your replies on this forum, to get to a stage when in reality it should open the web page without a great deal of fuss...

Mike

Reply With Quote
  #5 (permalink)  
Old January 30th, 2006, 05:44 PM
Imar's Avatar
Wrox Author
Points: 72,073, Level: 100
Points: 72,073, Level: 100 Points: 72,073, Level: 100 Points: 72,073, Level: 100
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 17,089
Thanks: 80
Thanked 1,587 Times in 1,563 Posts
Default

I am not sure I understand. Did you fix it or not?

I asked about the code from the book, to find out where the error might be. If the book's code runs fine, it must be in the steps you followed. In that case, you either missed something vital, or the book left something out.

By comparing your version with the one from the book, you may see where things went wrong...

Imar
---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.
Reply With Quote
  #6 (permalink)  
Old January 30th, 2006, 05:50 PM
Authorized User
 
Join Date: Jan 2006
Location: , , .
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi
The code from the book there was some faults,as I said i looked thru you messages in this forum and discovered many of the faults there, then I checked with the down load codes and found one ot two typing errors, as i said in the beginning every page works if done one by one but the final index page opens but displays nothing that why i have approached this forum.and message appears that blocknav is wainting for an object...

mike

Reply With Quote
  #7 (permalink)  
Old January 30th, 2006, 06:14 PM
Imar's Avatar
Wrox Author
Points: 72,073, Level: 100
Points: 72,073, Level: 100 Points: 72,073, Level: 100 Points: 72,073, Level: 100
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 17,089
Thanks: 80
Thanked 1,587 Times in 1,563 Posts
Default

And that's why I asked: does the code from the download work? If so, do you see a difference between that version and yours?

Also, can you post more specific error information and code?

I haven't written the part about Media Edge, so I can't help that much, but I'll try....

Imar
---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.
Reply With Quote
  #8 (permalink)  
Old January 30th, 2006, 06:27 PM
Authorized User
 
Join Date: Jan 2006
Location: , , .
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Imar

Hi
Icannot be any more specific as there are no faults showing with regards to the code, the code in the book was wrong, and some codes were missed in the book which i discovered from this forum, the only fault message i get is that the blocknav is waiting for an object, i have double even tripple checked the data base as i thought i might not be getting the information correct there. I do not understand why the index is not showing any informormation on it apart from the static items, this site which is supposed to work directly from the book to me has not been proof read at any time as a beginner at this type of work it should, at least do as it says it will do, without having to download pages for it to work or look at forums for missing information in the book.

Mike

Reply With Quote
  #9 (permalink)  
Old January 30th, 2006, 06:33 PM
Imar's Avatar
Wrox Author
Points: 72,073, Level: 100
Points: 72,073, Level: 100 Points: 72,073, Level: 100 Points: 72,073, Level: 100
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 17,089
Thanks: 80
Thanked 1,587 Times in 1,563 Posts
Default

Well, may be the book has been proof-read carefully (I know it has been), maybe everything works as expected and as advertised, but maybe you missed a step while reading through this book and carrying out these steps.

Again, I can only tell if you tell me if the book's version works. If you're not willing to "download pages" and see if those work, nor provide us with more information about pages, setup, source, code etc, there's not much I can do from here.

You have to help us help you.

Imar
---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.
Reply With Quote
  #10 (permalink)  
Old January 30th, 2006, 06:44 PM
Authorized User
 
Join Date: Jan 2006
Location: , , .
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Imar
The pages from the down load are exactly the same as i have on my site word for word coma for coma, checked and tripple checked,as i keep saying I'm realy only wanting to understand the reason why no images are apearing, if you could point me to an area where you might think it could be,i will probably solve it, because there is no fault codes appearing as` a fault it is hard for me to give you exactly what is happening.only that no site is appearing on the index page....and all other pages open when done on there own and all recordsets test okay..
Mike

Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Pop-Up Menu in DW MX 2004 Maverick Dreamweaver (all versions) 5 November 20th, 2004 12:08 PM
Reading XML in DW MX 2004 bommi_k Dreamweaver (all versions) 1 August 19th, 2004 01:07 PM



All times are GMT -4. The time now is 11:15 PM.


Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.